Chapitre 2. Démarrage rapide

Table des matières

Premier lancement
Création d'une configuration Apache.
Enregistrement d'un serveur
Ouverture de fichiers
Manipulation des fichiers de configuration Apache
Structuration des vues
Gestion des fichiers inclus
Ré-émission des directives
Validation et aides à la saisie
Mise en commentaire intelligente des directives
Génération de la configuration
Autres fonctionnalités d'édition

Premier lancement

Lors du premier démarrage de Kochizz, un assistant apparaît : il a été conçu afin de paramétrer automatiquement les principaux réglages du logiciel. Il est conseillé de l'utiliser car cela évite plus tard d'ajouter des configurations et des serveurs manuellement.

Le dialogue d'introduction récapitule les données que vous allez devoir saisir dans la suite du dialogue :

Cliquez sur "Suivant" pour afficher la page suivante.

Création d'une configuration Apache.

Cette page sert à définir la configuration Apache qui sera utilisée par défaut pour éditer les serveurs sur votre machine. Habituellement, comme une seule version d'Apache est utilisée sur votre ordinateur, une seule configuration a besoin d'être définie et chargée en mémoire. Néanmoins, si vous éditez des fichiers de configuration provenant d'autres versions d'Apache ou que vous souhaitez exploiter une aide à la saisie dans un autre langage, vous pourrez plus tard ajouter d'autres configurations dans le logiciel.

Si vous souhaitez créer la configuration maintenant, ce qui est recommandé, cochez la case "Créer la configuration par défaut maintenant". Saissez ensuite :

  • Le chemin d'accès à la documentation Apache. Les paquetages binaires de Kochizz est distribué avec la documentation correspondant à la version la plus récente du logiciel, et par défaut son chemin d'accès est entré dans le champ "Chemin du répertoire de documentation Apache". Vous pouvez entrer ici un autre répertoire si vous le désirez, celui-ci devant comporter les fichiers XML utilisés par les développeurs Apache pour générer la documentation des directives.

  • L'extension du langage définit la suite de caractères indentifiant la langue des fichiers de documentation à utiliser. Si vous laissez ce champ vide, la langue anglaise (".en") sera utilisée. Veillez à bien entrer dans ce champ le "." (point) avant l'extension de langue. Par exemple, la documentation Apache fournit une version allemande, pour l'utiliser il faut entrer ".de" dans ce champ pour utiliser les fichiers "*.xml.de" de la documentation Apache.

  • Le chemin du fichier de configuration Kochizz identifie le chemin d'accès au fichier de configuration principal (au format XML) qui définit certaines directives en détail afin que le logiciel puisse proposer un meilleur contrôle des données. Le chemin par défaut correspond au fichier installé avec le logiciel. Ce fichier est dépendant de la langue, vous pouvez donc être amené à le changer. Les langues disponibles sont une énumération de répertoires nommés par les deux lettres identifiant la langue. Ces répertoires sont fils du répertoire "directivesConf".

  • Vous pouvez également utiliser la documentation internet en cochant la case adéquate. Dans ce cas, lorsque vous demanderez à afficher l'aide sur une directive, la documentation HTML fournie en ligne par Apache.org sera affichée plutôt que la version locale fournie avec Kochizz. Cependant, la documentation locale XML sera toujours utilisée pour les bulles d'aide et la validation syntaxique.

Cliquez sur "Suivant" pour continuer.

Enregistrement d'un serveur

Vous pouvez dès maintenant enregistrer un serveur, c'est à dire nommer une configuration locale qui pourra être rechargée facilement ultérieurement. Cochez la case "Enregistrer le serveur par défaut maintenant" et spécifiez le fichier correspondant au fichier de configuration principal (celui qui inclut tout les autres). La majorité des distributions Linux utilisent pour Apache 2 le fichier principal "/etc/apache2/apache2.conf", comme il est indiqué sur la capture d'écran.

Enfin, vous pouvez choisir d'afficher le serveur à chaque démarrage en cochant la case "Charger ce serveur au démarrage". Dans tous les cas le paramètrage serveur sera associé à la configuration Apache précédemment saisie (si elle a été définie), et le serveur sera nommé "Serveur par défaut". Vous pourrez ultérieurement changer ce nom et sélectionner des options de pilotage et de contrôle en utilisant le gestionnaire de serveurs dans le logiciel.

Lorsque l'assistant a été terminé, la vue principale est affichée. Si vous avez enregistré un serveur il est chargé automatiquement. Vous pouvez directement vous rendre à la section intitulée « Manipulation des fichiers de configuration Apache ». Sinon, vous pouvez maintenant ouvrir un fichier à éditer comme décrit dans la section suivante.

Ouverture de fichiers

Lors du premier lancement, le logiciel apparaît sans configuration chargée, sauf si un serveur valide a été enregistré avec succès :

Pour ouvrir un fichier de configuration, déroulez le menu "Fichier" puis cliquez sur "Ouvrir". Vous pouvez aussi utiliser l'icône de dossier ouvrant dans la barre des menus :

Vous devez sélectionner un nom de fichier à ouvrir, une configuration de validation à appliquer ainsi que le suivi ou non des inclusions. Si aucune configuration Apache n'est exploitée, le contrôle des directives sera désactivé. De même, si vous désactivez le suivi des directives Include, les fichiers de configuration liés à celui qui vous souhaitez ouvrir ne seront pas directement éditables par Kochizz.

Lorsqu'un fichier est ouvert, Kochizz affiche d'abord l'ensemble de fichiers qui ont été analysés en fonction des éléments qu'il référençait :

Ensuite, Kochizz affiche sa vue principale.

Manipulation des fichiers de configuration Apache

Structuration des vues

Lorsqu'un fichier ou une configuration serveur est éditée, la vue principale est structurée en deux partie, comme le montre la capture d'écran ci-dessous :

Sur la gauche, l'arbre affiche uniquement les directives ouvrantes ou les directives d'inclusion. Sur la droite, deux vues affichant le "contenu" du noeud sélectionné dans l'arbre sont disponibles : la première affiche les données sous la forme d'un éditeur de propriétés, la seconde sous la forme d'un éditeur textuel avec mise en forme syntaxique. Lorsque vous sélectionnez un élément dans la partie gauche, le contenu à droite est automatiquement mis à jour. Dans l'éditeur de propriétés, vous pouvez également visualiser et modifier les commentaires associés aux directives dans la zone de texte en partie basse.

Pour modifier une valeur dans la vue des propriétés, il vous suffit de double cliquer sur la partie "Nom" ou "Valeur" de la liste. Dans le premier cas, si une configuration Apache est associée au fichier édité, une liste présente les directives pouvant être utilisées dans le contexte courant :

Vous pouvez supprimer une ou plusieurs propriétés en les sélectionnant puis en cliquant sur la touche "SUPPR". Vous pouvez également ajouter des nouvelles directives en double cliquant sur la dernière ligne de l'éditeur afin de lui affecter une valeur. Cela se traduira par la création en mémoire des directives correspondantes.

Vous ne devez dans cette vue insérer de directives ouvrantes ni de directives d'inclusion. Celles-ci sont réservées à la vue arborescente car elles identifient un groupe de directives qu'il n'est pas possible de modéliser dans l'éditeur de propriétés.

L'éditeur de texte permet quand à lui d'afficher les directives dans leur forme strictement textuelles, comme elles apparaissent sur le disque et telles qu'elles seront réécrites. La vue est réactualisée en fonction des modifications apportées, et sa modification entraîne également la mise à jour des autres vues.

De la même manière que vous pouvez éditer les directives graphiquement dans l'éditeur de propriétés, vous pouvez aussi modifier l'arborescence affichée sur la droite. Le même type de menu est affiché lors de l'édition, présentant les noms possibles pour la directive.

Gestion des fichiers inclus

Lorsque un fichier inclut d'autres fichiers, ceux-ci sont développés dans la vue arborescente comme fils des noeuds incluant. Si le chemin d'accès est relatif, le répertoire défini par la directive ServerRoot est utilisé pour le construire en totalité. Kochizz développe les expressions régulières afin d'afficher les fichiers inclus par le masque spécifié par la directive Include, chacun étant représenté par une icône de fichier portant le nom de fichier existant sur le disque (Kochizz manipulera automatiquement les éléments quelque soit leur fichier source) :

Lorsqu'une directive d'inclusion référence plusieurs fichiers existants (à l'aide d'expressions régulières, ou lorsque le lien pointe sur un dossier), vous ne pouvez pas modifier le nom ou le chemin des fichiers inclus car ils représentent des éléments qui ont une existence physique sur votre ordinateur. Pour les supprimer, effacez-les de votre disque dur, ou changez la destination du lien (les fichiers ne sont en aucun cas effacés du disque dur par Kochizz).

Lorsque vous ajoutez un noeud à une directive d'inclusion en utilisant le bouton "Ajouter un noeud enfant", Kochizz vous demande de choisir un nom de fichier. Celui-ci doit correspondre à l'expression régulière ou à la localisation indiquée par le texte de la directive, sinon, il ne pourra être ajouté à l'arborescence.

Lorsque vous avez créé des fichiers "en mémoire" (sans les sauvegarder) à l'aide de cette fonctionnalté, gardez à l'esprit qu'ils peuvent être "perdus" s'ils ne sont pas enregistrés et que vous modifiez le filtre de sélection de leur directive Include parente.

Ré-émission des directives

Lorsque vous souhaitez enregistrer les modifications apportées au fichier principal, il vous suffit d'utiliser la commande "Enregistrer" du menu "Fichier". Si vous voulez généraliser la mise à jour de tous les fichiers de la configuration, vous pouvez procéder de la manière suivante :

  • Si vous éditez un serveur, cliquez sur "Génération" puis "Regénérer toute la configuration". Tous les fichiers seront réecrits à leur emplacement original. Lorsque Kochizz pourra utiliser des protocoles comme SFTP, FTP ou SSH pour transférer les configurations, cette fonction utilisera automatiquement le protocole associé au serveur pour mettre à jour les fichiers.

  • Si vous éditez un fichier seul, il faut demander la génération des fichiers à leur place originale. Utilisez le menu "Génération", puis "Génération locale" et enfin "Ecraser les fichiers".

Les opérations de génération peuvent nécessiter des droits élevés comme détaillé en introduction.

Validation et aides à la saisie

Lorsqu'aucune configuration Apache n'est associé à l'objet édité, Kochizz ne propose pas la liste déroulante affichant les objets pouvant être insérés, et ne vérifie pas que les directives que vous entrez sont valides on non. Les directives sont toutes affichées en noir.

Dans le cas contraire, les codes couleur suivants sont utilisés :

  • Bleu: la directive est contrôlée, et valide.

  • Rouge: la directive et ses paramètres ne sont pas autorisés.

  • Orange: la directive n'a pas été insérée dans la bonne vue (par exemple, vous avez inséré une directive Include dans le gestionnaire de propriétés)

L'arbre de la colonne de gauche de Kochizz et l'éditeur de propriété proposent les directives possibles selon leur contexte (la directive parent) en analysant la documentation Apache. Toutefois, l'édition manuelle d'une directive non ou mal documentée reste possible, elle sera alors simplement signalée par Kochizz comme non reconnue mais restera prise en compte et réécrite à la sauvegarde. L'éditeur de texte ne propose pas d'analyse contextuelle.

L'éditeur de texte utilise un système de soulignement typique des traitements de texte pour signaler les directives non reconnues :

Les directives reconnues apparaissent en bleu et les commentaires en vert.

Enfin, Kochizz insère quand c'est possible des bulles d'aide expliquant le rôle des directives ou la valeur qu'elles doivent prendre. Les textes sont extrait de la documentation et varient donc en fonction de la langue de la configuration que vous avez choisi :

Mise en commentaire intelligente des directives

Chaque directive possède, dans la vue arborescente et dans l'éditeur de propriétés, une case à cocher qui permet de la désactiver (elle et toutes les directives qu'elle contient dans le cas d'une directive ouvrante). Cette fonctionnalité permet de rendre commentées des directives pour Apache alors qu'elles restent identifiables en tant que telles pour Kochizz, sans être réduites à l'état de pur commentaires.

Lorsqu'une directive est désactivée, elle apparaît en vert dans l'arborescence et en italique dans l'éditeur de propriétés :

En réalité, Kochizz fait précéder la directive d'une chaîne particulière vue comme commentaire par Apache et détectée comme élément "neutralisant" par le logiciel. Vous pouvez donc vous servir de cette fonctionnalité pour désactiver temporairement des directives ou des branches associées à des directives pour mettre en service des hôtes virtuels. Cette chaîne particulière de commentaires est visible dans l'éditeur de texte.

Génération de la configuration

Nous avons vu précédemment comment regénérer l'intégralité d'une configuration chargée. Vous pouvez également choisir d'autres options de générations en utilisant les sous-menus placés dans "Génération", "Regénération locale" :

  • "Générer dans un répertoire" permet de réecrire tous les fichiers dans un répertoire particulier que vous spécifiez ensuite. Cela permet de visualiser rapidement l'intégralité d'une configuration modifiée à des fins de déboguage. C'est aussi utile lorsque vous souhaitez récupérer tous les fichiers modifiés d'une configuration alors que vous ne possèdez pas assez de droits pour les réecrire à leur emplacement original.

  • "Tout dans un fichier unique" permet de rassembler toute une configuration dans un unique fichier, dont la cohérence reste assurée. Les directives Include sont remplacées par le contenu des fichiers vers lesquels elles pointaient. Le fichier peut être utilisé à des fins de test ou transféré sur un autre poste pour tester la validité du paramètrage sans devoir échanger tous les fichiers qui le composent sur le poste source.

Vous pouvez configurer les options de génération en utilisant la boite de dialogue affichée par Edition|Préférences dans l'onglet "Paramètres de génération" :

Vous pouvez dans ce dialogue choisir d'activer ou non l'indentation automatique des fichiers. Lorsque cette option est activée, ce qui est le cas par défaut, le générateur indente (décale) les directives ouvrantes et leur contenu proportionnellement à leur niveau d'imbrication dans le fichier. Dans ce cas, les espaces ou les tabulations peuvent être choisis comme caractère de séparation. Vous pouvez également choisir une extension particulière avec laquelle les fichiers existants qui seront écrasés devront être renommés. Si aucune extension particulière n'est renseignée, les fichiers devant être écrasés seront réécrits sans sauvegarde de leur contenu.

Autres fonctionnalités d'édition

Kochizz permet de couper, copier, coller, et effacer les éléments des différentes vues. Vous pouvez utiliser pour cela les éléments des menus ou utiliser directement les raccourcis clavier équivalents.

Vous pouvez copier un extrait de fichier de configuration dans l'éditeur de propriétés et les lignes correspondantes seront automatiquement créées dans la vue d'édition.

Le glisser déposer est possible dans l'éditeur arborescent afin de déplacer des branches entières de directives dans la même configuration. Si la touche SHIFT est pressée, la branche sélectionnée n'est pas déplacée mais copiée. NB : le déplacement en glisser/déposer ou le couper/coller n'est pas fonctionnelle avec la version 4.3.0 de Qt (une copie est effectuée). La version 4.3.1 de Qt corrige ce problème.

Vous pouvez aussi chercher des expressions en utilisant le sous menu "Chercher" du menu "Edition". La recherche est effectuée dans la vue active et commence au début du document sélectionné. Utilisez le menu "Rechercher le suivant" pour trouver la valeur suivante (si elle existe) qui satisfait la chaine recherchée.